Services Down
Resolved·Full outage

Our authentication provider suffered an outage which caused Everbility services to be unavailable. The incident has been resolved now and there was no impact on any data stored on Everbility.

Thu, Jun 26, 2025, 07:30 AM
(13 hours ago)
·
Affected components
Data Access
AI Services
Login
Updates

Resolved

Our authentication provider suffered an outage which caused Everbility services to be unavailable. The incident has been resolved now and there was no impact on any data stored on Everbility.

Thu, Jun 26, 2025, 07:30 AM

Monitoring

We are seeing a recovery across all our services as our upstream vendor recovers.

Thu, Jun 26, 2025, 07:02 AM(28 minutes earlier)

Identified

One of our upstream vendors is having an outage which is impacting our ability to provide services. We are monitoring the situation and will be providing further updates here. This does not impact any data stored on Everbility.

Thu, Jun 26, 2025, 06:34 AM(28 minutes earlier)
Powered by